XPro2

Fuji X-Pro2 First Impressions

I want to make it clear this is not a review. These are my first impressions of MY copy of the newly released Fuji X-Pro2


 

I posted a similar thread the other day and my post was met with a lot of mean-spirited attacks. If you feel the need to call me an idiot or any other pejorative term I will report you as spam.

 


 

I purchased my copy of the X-Pro2 March 4th. I used it for a photo shoot March 6th. I was using my Quantum T5D-R* as off camera flash triggered by Pocket Wizards. The “on camera” transmitter was a Pocket Wizard MiniTT1 for Canon.  If you know anything about Pocket Wizards you know that the MiniTT1 can be set in basic triggering mode which causes it to act like any other Pocket Wizard. The flash had a PlusX attached as the receiver.  The lens I was using the 50-140mm f2.8 R LM OIS WR.

While shooting I got a “internal temperature warning” screen.  I turned off the camera and when I  turned it back on and got the same screen.  To the touch nothing felt warm, much less hot.  When I removed the OEM battery it felt fine.   In short, the tactile heat inspection of the camera and battery passed with flying colors. I then changed the transmitter from the MiniTT1 to a PlusX and didn’t have this issue for the rest of the shoot.  I also noticed that my camera setting had completely reset to the factory original settings.  I did call Fuji and gave them this information and they said they would pass it on to Japan.  Very nice person at customer service by the way.

To be fair, the issue could have been with the MiniTT1 but I’ve never had this issue when I used the MiniTT1 with my XT-1, XE-2, Pentax 645z or Leica M Type 240.  My guess is that Fuji will provide a firmware fix shortly. One great thing about Fuji is they do an excellent job providing firmware updates.  I did call and talk to Pocket Wizard support as well.  They confirmed that the fact the MiniTT1 was for Canon is a non issue seeing how it is designed to work with any camera as a basic flash trigger.  The TTL functionality specific to Canon has zero affect on the basic triggering mode.

One other thing I noticed was the slow write speed.  I was using Delkin 633x SD cards and it was noticeably slow.  But I have since purchased Lexar 1000x cards and no longer have an issue withe write speed.  The AF seems a good, maybe slightly better than my XT-1. Again, this is just my eyeball test.  Nothing scientific here.

I feel compelled to state one more time that these are MY first impressions of MY X-Pro2. I had the X100 in my hands the day it came out, same with the X-Pro1. I have been sooting Fuji X system for wedding sine 2013.  Yes, I know how to set the camera settings.  No, I’m not an idiot.  THIS IS NOT A REVIEW

*I have since switched to the Elinchrom Ranger Quadra for my location lighting.

UPDATE

I connected the MiniTT1 to the X-Pro2 again with a different battery and lens and itmdidmthe same thing.  As soon as I powered up the camer I received the internal temperature warning.  Used the MiniTT1 On my other cameras with zero issue.  Also if you follow the Fuji X Forum you will read a lot of posts about a lot of issues with the X-Pro2.

PROBLEM IDENTIFIED:  The X-Pro2 has the additional flash hot shoe post for supplying power to the flash much like that of the XT-1.  This extras post seems to be the culprit.  I will find out of the solution I’ve come up with fixes the issue permanently.  That solution being, buying a single post hotel short adapter and mounting the MiniTT1 to it and therefore bypassing the power supply post on the cameras hot shoe.